Softの最近のブログ記事

前の10件 2  3  4  5  6  7  8  9  10  11  12

いい感じなのはまだ最初だけみたいな、俗称Windows 8(でも実は6.2)のX121e。
角が丸くなくなったのはテーマなんだろうし、別にいいんだけど、タイトルバーを有効に使うようになったらしいのは評価大ってのはまた別の話で、どうにも初期設定とかやりにくくなってる気がする。

たとえば、デバイス認識を確認するためにデバイスマネージャを・・・見つからん!みたいな感じ。

今までならスタートからマイコンピュータ右クリックの管理でなんでもできたんだけど・・・

デスクトップにコンピュータを表示するか、エクスプローラー起動(Win+E)したあと、コンピュータを右クリックの管理で何とか。

ふむふむ、デバイスすべてを自動認識できているわけじゃないと。
指紋認証とか、SM Bus Controllerとか、サウンド関連が不明なデバイスになってるっぽい。
逆にBluetoothとか無線LANとかは自動で認識されてるっぽい。

不明なデバイスも分かったので、ドライバをインストールしてみますか。
Windows 7用のドライバインストールうまくできればいいのだが・・・

初心者とかプリインストールマシンならこういう設定って不要だし、隠ぺいしちゃってもいいんだろうけど、ちょっと弄りたい人とかには不親切。
逆に、管理者はやりたい放題ってことかも知れず、俺的には、ちょっとなぁという感じ。

アレするたびにカクカクするのはPreview版だからとしても。

まっさら状態のThinkPad X121eを用意できたので、Windows Developer Previewをインストールしてみた。

インストールしたのは、with developer tools and apps。
もちろん、64bit版。

インストールメディアのディスクサイズ的には2層DVDを必要とする。
まぁ、ディスクはあるけど、これだけのために焼くのもナンだし、USBメモリでインストールしてやろうと思い、XCOPYしてみる。

で、うまくいかないわけよ、XCOPYがさ。

と言われるのは仕方ない。
SQL Server 2008 R2でのこと。

SQL Server Management Studio のデータベース ユーザーのプロパティで、ついつい「このユーザーが所有するスキーマ」というリストのどれでもチェックしてOKしちゃうと、次回以降、そのチェックを外すことができなくなって、ユーザを削除しようとしても、掲題のメッセージが出て削除できないという状態に陥る。

そりゃスキーマ所有したんだから、メッセージの通りなんだけど、所有解除ってどうやんの?ってところで軽く躓く。

サーバー化する

| コメント(0) | トラックバック(0)

X121eにWindows Server 2008 R2 Datacenterをインストールしてみた。

デバイスドライバはほとんどインストールできて、Aeroも有効にしたんだけど、1点だけ、BTドライバのインストールができていない。

なんかで失敗してドライバでエラーになる。

という問題があるものの、些細なことだから無視する。
#サーバだから直接操作することは少ないだろうし。

再インストールで確認したいのだが、それよりも先に、Hyper-Vを試しておきたいところ。

ちゃんと実用レベルで使えるなら、もしかして、3台くらい用意すれば、ライブマイグレーション対応のシステム組めるんじゃねぇ?とか思ってる。
トータル20万円(OS除く)もせずに。
しかも、モバイル可能ときた。

でも、モバイルするの重たいよな・・・

仮想ぬか喜び

| コメント(0) | トラックバック(0)

たしかKDEだったからCentOSopenSUSEだったかと。

確かにログインして、startxして、デスクトップ起動したんですよ。

Ext4で3.2GBほど喰ってたのを見たし。

きちんとシャットダウンもしたはず。

なのに、再度立ち上げたら、セットアップ未完了とかでエラーになる始末。

どういうことですか。

カーネルとか新しいやつはダメなのかしら?

仮想SUSEも詰まる

| コメント(0) | トラックバック(0)

Windows7のVirtualPCにLinuxをインストールするのは無理なのか?

今度はopenSUSEをインストールしてみたのだが、結果はよろしくなく。

一度はログインまで行ったのだが、GUI立ち上がらず。

X121eだとダメなのか?

よくわからん。

仮想Vineに苦戦

| コメント(0) | トラックバック(0)

Vine6.0をX121eのVirtual PC(Windows 7)に突っ込んでみたんだけどなんかうまくいかない。

DVD ISOイメージ落としてきてインストール。
でも、失敗続き。

失敗すると、VMが終了する有様。

オプションでテキストインストールを選択し、電源に接続してやっとインストール完了と思いきや、再起動後にチェックサム違反とかで、やはりVM終了。

どういうこっちゃ。

インストールの際に電源接続したらうまくいったので、もしかすると、省電力関係の何かが邪魔しているのかも知れないと思うも、電源接続しなきゃ使えないんじゃ、ノートPCへのインストールに意味がなくなるわけで、・・・

他のディストリビューションで試してみますかね。

いろいろ動くぞ

| コメント(0) | トラックバック(0)

Windows 7を常用してたのがネットブックだったため、7のVirtual PCでも64bit不可能というのを知ったのが、今日だったりする。

やはり、Hyper-Vじゃないと、64複数は難しいっぽい。

というわけで、X121eでも、当然余裕でXP Modeとか動いちゃうわけですよ。
#当然、対応Editionに限る。

ただし、デフォルトのBIOS設定で仮想化設定無効なので、有効にしてやる必要があるので、それだけは注意。
#もしかすると、設定変更後、一旦電源を落とす必要があるかも。

なんにせよ、大変よろしゅうござる。

解決はしていない。

とあるサイトというのは、某ショップのサイトだったわけだが。

とりあえず、店舗の方に直接確認してもらった。
#こういうとき、WiMaxだと持ち運び自由で便利。

だけど、原因、掴めないままで、結局、店舗サイトをfne.jpでリバースプロキシすることに。

で、その設定が何とかできたのだが・・・なんだかおかしい現象に。

URL Rewriteのバージョンが古いのかも知れないけれど、リダイレクトヘッダの書き換えがおかしい。

http://Aのパターンをhttps://nA.fne.jpに書き換え、https://Aのパターンをhttps://sA.fne.jpに書き換えているとすると、リダイレクトヘッダのLocationで、明らかに後者なのに前者に書き換えられてしまう。
後続HTMLコンテンツ内の後者パターンはちゃんと書き換えできているのに。

よくわからないけれど、このままではいろいろと問題なので、URLパターンを解析して、強制的に自主的リダイレクトを追加。
これによって何とか、何とか。

本当は汎用のリバースプロキシを実装すればいいんだけど、文字コードの件もあるので、それは追々。

 

ホスト名は無関係?

| コメント(0) | トラックバック(0)

前回までは・・・

Hostヘッダが怪しいんじゃねぇ?→Host名.fne.jpサイトを作ってアクセス→プロキシ動作させるのに悪戦苦闘の末成功→当初の目的を忘れる。

だったわけだが、今回、hostsを書き換えて、完全同一ホスト名でアクセス可能かやってみたわけよ。

結果、プロキシアクセス成功。
なんでやねん!!

前の10件 2  3  4  5  6  7  8  9  10  11  12

サイトカウンタ

Total: 211,632 Hits, (Recent24Hours: 0 Hits)
~ Since 2010/01 ~

埋め込みツイッター

取得失敗;;
Now: 2019/03/19 18:52:48 JST

このアーカイブについて

このページには、過去に書かれたブログ記事のうちSoftカテゴリに属しているものが含まれています。

前のカテゴリはHobbyです。

次のカテゴリはStudyです。

最近のコンテンツはインデックスページで見られます。過去に書かれたものはアーカイブのページで見られます。

2019年3月

 日   月   火   水   木   金   土 
          1 2
3 4 5 6 7 8 9
10 11 12 13 14 15 16
17 18 19 20 21 22 23
24 25 26 27 28 29 30
31            

埋め込みQRコード